落絮飞雁的个人网站

顺流而下,把梦做完

据说是最适合Chromebook的发行版

又来折腾Chromebook了,这次试了一下GalliumOS。 READ MORE →

写写Chromebook上用过的系统

入手Chromebook一年多了,写写适合Chromebook用的系统。 READ MORE →

Ubuntu安装postfix的步骤

VPS上安装好WordPress之后,另一件要做的事就是配置邮件传输代理。 READ MORE →

解决关闭笔记本盖子后SSH断开的问题-Ubuntu

旧笔记本拿来做了 Ubuntu Server。但是发现在合上笔记本盖子后SSH会断开,摸索了一下解决方案:
READ MORE →

SSH命令行下升级Ubuntu

写在前面:Ubuntu不推荐用SSH进行升级,因为『升级失败时较难恢复』,且在升级之前会创建一个SSH守护进程(1022端口)。因此建议在通过SSH升级之前先在防火墙上打开对应端口。

升级步骤:

1)先升级系统软件:

2)重启电脑后安装update-manager-core:

3)然后编辑/etc/update-manager/release-upgrades

将Prompt=lts改成Prompt=normal

然后保存关闭

4)最后执行升级:

即可完成对Ubuntu的升级。

参考:纯命令行方式升级ubuntu系统| 佐井

N卡的痛——Ubuntu下禁用独立显卡

转载自:推酷网

这篇文章实例演示Ubuntu13.04/13.10下,双显卡笔记本(intel+Nvidia)如何关闭独立显卡NVIDIA,用到的工具是bumblebee,操作非常简单,关闭独立显卡后,可以使用optirun命令调用它。

安装bumblebee

Ubuntu13.04在安装好后,默认使用的是Intel集显,Nvidia卡除了在那里发热以外,没有任何作用,这一步我们将使用bumblebee来关闭Nvidia卡,等到需要的时候再调用它。

请注意bumblebee中包含了Nvidia卡驱动,请不要再自行安装驱动。

安装bumblebee

Ubuntu VPN连接失败解决方案

我用系统自带的“网络管理小程序” 建立VPN,用的是PPTP协议,连接时总提示连接失败,

查看系统日志中的 Messages项中,有一段提示:
Dec 18 13:11:53 liaoxiaohui-Unknow pppd[3524]: Plugin /usr/lib/pppd/2.4.5//nm-pptp-pppd-plugin.so loaded.
Dec 18 13:11:53 liaoxiaohui-Unknow pppd[3524]: pppd 2.4.5 started by root, uid 0
Dec 18 13:11:53 liaoxiaohui-Unknow pppd[3524]: Using interface ppp0
Dec 18 13:11:53 liaoxiaohui-Unknow pppd[3524]: Connect: ppp0 <–> /dev/pts/1
Dec 18 13:11:58 liaoxiaohui-Unknow pppd[3524]: CHAP authentication succeeded
Dec 18 13:11:58 liaoxiaohui-Unknow pppd[3524]: LCP terminated by peer (MPPE required but peer negotiation failed)
Dec 18 13:11:58 liaoxiaohui-Unknow pppd[3524]: Modem hangup
Dec 18 13:11:58 liaoxiaohui-Unknow pppd[3524]: Connection terminated.
Dec 18 13:11:59 liaoxiaohui-Unknow pppd[3524]: Exit.
MPPE required but peer negotiation failed  这个就是提示数据没有加密,而对方服务器,必须要求加密才能连接,
所以勾选上 VPN连接中的 MPPE就可以了,MPPE就是使用点对点加密 Use Point-point encryption
Use Point-point encryption  : 它使用的是MSCHAP 和MSCHAPV2版的加密算法
如果是windows的话,可能默认就勾选了
转自:http://blog.163.com/sg_liao/blog/static/295770832010111812110294/

又见ubuntu软件中心崩溃

本来想在ubuntu上面安装个wps玩玩的,结果安装的时候出现了一个warning,随手忽略掉,结果……问题来了…………

ubuntu软件中心崩溃,总是闪退,看到说软件中心崩溃很多时候是因为list错误,需要手动更新list。试了一下,不行……好吧,那我就用新立得好了,用apt-get安装新立得,结果居然不行!

报错是:

E: 软件包 wps-office 需要重新安装,但是我无法找到相应的安装文件。

看来是没有卸载wps就什么也安装不成啊,试着又下载了一个wps放在那里,还是不行,快晕死了…………

又试了试清理ubuntu缓存,怎么还是不行……快无语了……

最终还是用sudo强制卸载wps-office解决了问题,命令如下:

sudo dpkg –remove –force-remove-reinstreq wps-office

好了,问题解决~