落絮飞雁的个人网站

顺流而下,把梦做完

解决OpenWRT下ngrok无法启动的问题

ngrok作为一款内网穿透工具,可以很方便的把内网设备映射到公网访问。不少路由器固件上都集成了这个工具。最近在两台路由器上设置ngrok时遇到了不能启动的问题。

READ MORE →

用旧摄像头和开发板搭建监控平台

一个旧摄像头的奋斗 READ MORE →

设置Openwrt为二级路由

手头的WR703n只有一个网口。刷过Openwrt之后通过修改配置来连接上级路由的简单方法。网口为WAN口,LAN只能通过wifi连接。

/etc/config/network:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.76.1.1'
	option netmask '255.255.255.0'


 

ar71xx可用Openwrt软件源

  • Openwrt官方:

http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/packages/

  • Openwrt中文:

http://downloads.openwrt.org.cn/backfire/10.03.1/ar71xx/packages/

  • 爱好者自建:

http://openwrt.herokuapp.com/snapshots/trunk/ar71xx/packages