落絮飞雁的个人网站

顺流而下,把梦做完

瞎折腾家里的网络布线

上次调整过后家里的网络一切正常,缺点在于分成两个子网之后NAS不能很方便的被另一个子网的设备访问,当时的解决方法是手动打开防火墙端口。不过随着NAS上的服务越来越多,配置防火墙也就越来越复杂了,这些都能接受。诡异的是,几个月后父亲说家里网络不能上网了,而我远程连上家里的路由器却发现并没有发现异常,于是趁这次回家又来折腾一下网络。

READ MORE →

折腾家里的网络布线

在杭州的时候,爸妈就抱怨家里的网不好,卡到甚至要用流量卡来上网。于是趁过年回家折腾了一下网络。

READ MORE →

网络布线的碎碎念

前几天在办公室里组网,从头到尾完成。 READ MORE →

OpenWRT设置访客网络

设置访客网络,保护内网安全。
READ MORE →

Openwrt实现无线MAC过滤

在Luci的界面下(网络-无线-无线概况-修改-接口设置)中可以添加MAC过滤。但添加之后会导致所有无线设备都无法连接的BUG。
本文讲通过直接修改对应文件的方式来实现MAC过滤。
SCP链接到路由器,依次展开/etc/config,编辑wireless文件。
在config wifi-iface后依次添加:

	option macfilter 'allow'
	list maclist 'XX:XX:0C:85:67:09'
	list maclist 'XX:XX:0B:71:28:CA'

将需要设置的MAC地址填入maclist,保存。 ‘allow’表示MAC白名单。设置完毕后重启路由或是重启wifi即可。


参考:
Openwrt无线方面的设置-Openwrt wiki
OPENWRT 怎么没找着在哪设置MAC过滤-恩山

设置Openwrt为二级路由

手头的WR703n只有一个网口。刷过Openwrt之后通过修改配置来连接上级路由的简单方法。网口为WAN口,LAN只能通过wifi连接。

/etc/config/network:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '10.76.1.1'
	option netmask '255.255.255.0'


 

ar71xx可用Openwrt软件源

  • Openwrt官方:

http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/packages/

  • Openwrt中文:

http://downloads.openwrt.org.cn/backfire/10.03.1/ar71xx/packages/

  • 爱好者自建:

http://openwrt.herokuapp.com/snapshots/trunk/ar71xx/packages

DD-WRT做二级路由的设置方法

主路由不用动,开DHCP即可。

二级路由先连电脑,后台设置:

禁用WAN口,设置IP与主路由同一网段且无冲突。网关留空。关闭DHCP服务器。

如图:

网线连接主路由LAN口和二级路由WAN口。

沉稳大气——入手网件WNDR4300

暑假在萧山,因为手头没有路由器,就一直在研究入手一块新的路由折腾玩玩。赶上rg100aCFE刷机失败,就剁手了网件的WNDR4300这块路由。一来是觉得网件的路由器比较稳定,拿来作为主力路由不要出太多状况;二来觉得4300的样子真的好漂亮……立式的又是内置天线,一排指示灯亮在那里甚是好看~Excited!


奶茶家的物流确实快,晚上拍下的,第二天上午就发短信提醒我取件了。先上一张图:

 

放上全家福一张,送的网线质量很赞,带金属屏蔽的。

要说的是,左下的支架是只能插在路由器左侧的。也就是说,路由器最好放在桌面右侧,否则路由器的面板会挡住前面的指示灯。


话不多说,看下网件的路由后台。说实话,界面设计的的确不够友好(TP-link除外= =),但是首页还是设计的比较清爽的。路由状态一目了然。如图:

然后说下几个特色功能:

首先当然是支持DLNA+SMB协议啦,这样就可以躺在床上看视频了,即便是1080P视频拖动时缓冲都可以忽略不计。这点比rg100强太多了。而且DLNA应用比较广,之后还可以跟电视一起用。

其次是网件的离线下载:这个功能貌似是国行才有的。支持HTTP/FTP、电驴、磁力链、BT种子。基本上主流的下载协议都支持,常用的设置也是一应俱全。还是很实用的。而且还能在下载完毕后邮件通知(可设置)。缺点:UI设计的貌似有点问题,在ipad上总是不能把下载链接拷贝到地址栏里(需要依次按住地址栏——出现放大镜——继续按住往上拖——在空白处出现的菜单中选择“全选”——这时候光标才会出现在下载地址栏,并出现“粘贴”按钮)。而且又是会出现莫名的暂停,选择“恢复”按钮无效。必须重新添加任务。

还有就是访客网络:可以独立设置出一个热点让别人连,但是跟你的无线网络是分开的,不能访问到你的共享信息,而且互相之间也不能访问到。可以拯救一下没有路由器的小伙伴。

还有就是网件精灵:一个路由器的客户端,可以看多少设备连接到路由器上,发现陌生设备还会报告。流量大的时候也会提醒,还可以向其他装了网件精灵的设备传文件(国际惯例没有WP版本……)。

这些基本上就是目前能用到的功能了。总体印象是稳定、强大。暂时还没有找到什么太明显的缺点。很多人提到的信号弱的问题也没有出现。(可能是在寝室用不穿墙吧,但是在无线设置页面看到的地区设置。都懂的。)。十分满意的一块路由。

 

 

折腾暂告段落……

根据相关法律法规和政策 部分内容未予显示。

开学之后一直在折腾路由器~手头的这台RG100a已经服役两年多了,依然在运行各种服务~
拨号上网这种自然不必多讲。除此之外,还做了一个Transmission来离线下载,可惜由于机能限制,不敢放开速度。有时候任务一多就宕机了……一声叹息。
除此之外,还搭建了一个访客网络。供串门的小伙伴来用。

就这样,100a性能就被压榨殆尽了。

附照。